When an error prevents CFITSIO to open the FITS file, the error message of its status is brought up to the user level, for an easier debugging.

As usual, to install or re-install the latest version of QLFits3, use the one-line installer:

curl -fsSLk https://raw.github.com/onekiloparsec/QLFits/master/Scripts/install.sh | sh